Atom feeds not working in phpbb

Patches and other information
Post Reply
Steve
Posts: 62
Joined: Sun Oct 01, 2017 3:08 pm

Atom feeds not working in phpbb

Post by Steve » Sat Jan 20, 2018 5:35 pm

After the recent upgrade to phpBB 3.2 my feeds generate an error. After some trial and error, I found adding /app.php/feed after the url allows feed access. The rewrite commands in phpBB htaccess are supposed to remove app.php from the URL but there appears to be a disconnect somewhere in the routing. The URL displays correctly in the browser but you get a to many redirects message. Firefox displays: "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."
Chrome displays: "The page isn't working skdavis.net redirected you too many times".

After going through all this trouble I found some posts on phpBB: Board feed stopped working after going from 3.1.10 to 3.2.1 (too many redirects) and .htaccess not working migrate punBB to phpBB

To get your feed icon(s) to work when selected, login to ACP and go to to Server Settings>Enable URLRewriting and select No. Feed icons will work properly but the URL access your phpBB board wide feed will be:

Code: Select all

http://yourdomainname/app.php/feed
While it is best to disable URLRewriting, adding the following code just before the last </ul> in the navbar_header.html file will place a functioning feed icon in the navbar. The URL will still contain app.php/feed so it's really easier to turn URLRewriting off instead of adding additional code. Additionally this code will not fix the URLs for individual forum feeds if URLRewrites are enabled.
(You must replace your_domain_name in the code below with your domain name)

Code: Select all

		<!-- IF S_ENABLE_FEEDS and S_ENABLE_FEEDS_OVERALL -->
			<li class="rightside" <span><a type="application/rss+xml" class="feed-icon-forum" title="{L_FEED} - {SITENAME}" href="https://your_domain_name/app.php/feed"><i class="icon fa-rss-square fa-fw icon-orange" aria-hidden="true"></i><span class="sr-only">{L_FEED}</span></a></li>
		<!-- ENDIF -->
WordPress uses the same type of Rewiterule so I tested WordPress permalinks and the URL rewrites work perfectly on the same server running phpBB. A bug has been submitted and confirmed atom feed using http-auth.

Post Reply